Follow

RT @bisq_network
Reminder: 1.7.0 will become the minimum required version for trading very soon...so upgrade if you haven't already!

. twitter.com/bisq_network/statu

Sign in to participate in the conversation
Bitcoin Mastodon

Bitcoin Maston Instance